What’s Vulnerable › Vulnerabilities
CVE-2026-45067: Symfony: Email Header / SMTP Command Injection via CRLF in Symfony\Component\Mime\Address
- Severity: medium (CVSS 6.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-07-14
- Weakness: CWE-93
Description
### Description `Symfony\Component\Mime\Address` is the value-object every Symfony Mailer address (to/cc/bcc/from/reply-to) flows through; its constructor is documented as validating the address and throwing on invalid input, so developers treat it as a security boundary. The constructor accepts email addresses whose local-part (the part before `@`) is an RFC-5322 *quoted string* containing raw `\r\n` bytes — e.g. `"x\r\nBcc: attacker@evil"@example.com`. The stored address is later emitted verbatim into (1) the rendered message headers and (2) `SmtpTransport`'s `MAIL FROM:<...>` / `RCPT TO:<...>` protocol lines, turning the embedded CRLF into a new mail header and/or a new SMTP command. ### Resolution The `Address` constructor now rejects addresses containing line breaks. The patch for this issue is available [here](https://github.com/symfony/symfony/commit/dc2dbd29211eb4ddc451373fa1374fb926e94604) for branch 5.4. ### Credits We would like to thank Claude Mythos Preview (via Project Glasswing) for reporting the issue and providing the fix.
Affected products
- Packagist Symfony/Mime: before 5.4.52; from 6.0.0 before 6.4.40; from 7.0.0 before 7.4.12; from 8.0.0 before 8.0.12; v4.3.0, v4.3.0-BETA1, v4.3.0-BETA2, v4.3.0-RC1, v4.3.1, v4.3.10 (+253) — fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
- Packagist Symfony/Symfony: before 5.4.52; from 6.0.0 before 6.4.40; from 7.0.0 before 7.4.12; from 8.0.0 before 8.0.12; 2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.11 (+696) — fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
- symfony: before 5.4.52; from 6.0.0-BETA1, < 6.4.40; from 7.0.0-BETA1, < 7.4.12; from 8.0.0-BETA1, < 8.0.12
How to fix
Upgrade to a fixed version: Packagist Symfony/Mime 5.4.52, 6.4.40, 7.4.12, 8.0.12; Packagist Symfony/Symfony 5.4.52, 6.4.40, 7.4.12, 8.0.12. Check the vendor advisory for mitigations.
References
- https://github.com/symfony/symfony/commit/a1c42cbe517bc146a54da7505a107ded317478fe
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12
- https://github.com/symfony/symfony/security/advisories/GHSA-qpmx-3rfj-7rhv
Get alerted when CVE-2026-45067 or the next vulnerability affects your stack