What’s Vulnerable › Vulnerabilities
CVE-2026-45071: Symfony: XXE (Local File Disclosure) in DomCrawler::addXmlContent() via validateOnParse = true
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-07-15
- Weakness: CWE-611
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Crawler::addXmlContent() set DOMDocument::$validateOnParse = true before loadXML(), re-enabling external entity resolution and allowing attacker-supplied XML to expand file:// entities such as local files. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Affected products
- symfony: before 5.4.52; from 6.0.0 before 6.4.40; from 7.0.0 before 7.4.12; from 8.0.0 before 8.0.12 — fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
- Packagist Symfony/Dom-Crawler: before 5.4.52; from 6.0.0 before 6.4.40; from 7.0.0 before 7.4.12; from 8.0.0 before 8.0.12; 2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.12 (+590) — fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
- Packagist Symfony/Symfony: before 5.4.52; from 6.0.0 before 6.4.40; from 7.0.0 before 7.4.12; from 8.0.0 before 8.0.12; 2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.11 (+696) — fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
How to fix
Upgrade to a fixed version: symfony 5.4.52, 6.4.40, 7.4.12, 8.0.12; Packagist Symfony/Dom-Crawler 5.4.52, 6.4.40, 7.4.12, 8.0.12; Packagist Symfony/Symfony 5.4.52, 6.4.40, 7.4.12, 8.0.12. Check the vendor advisory for mitigations.
References
- https://github.com/symfony/symfony/commit/eea5fd7488cbdc241da4ce242344b7d9a3ecdf3d
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12
- https://github.com/symfony/symfony/security/advisories/GHSA-x6g4-fwcc-jj8w
Get alerted when CVE-2026-45071 or the next vulnerability affects your stack