What’s Vulnerable › Vulnerabilities
CVE-2026-45073: Symfony: SQL Injection in PdoAdapter::doClear() via Unsanitized $prefix
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-89
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, PdoAdapter::doClear() builds a DELETE statement using a namespace derived from the caller-supplied $prefix without binding or escaping it, allowing a caller able to influence $prefix to break out of the LIKE literal and alter query semantics or deletion scope. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Affected products
- symfony: before 5.4.52; from 6.0.0 before 6.4.40; from 7.0.0 before 7.4.12; from 8.0.0 before 8.0.12 — fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
How to fix
Upgrade to a fixed version: symfony 5.4.52, 6.4.40, 7.4.12, 8.0.12. Check the vendor advisory for mitigations.
References
- https://github.com/symfony/symfony/commit/ec50b799d79ebe24561f29351c1efcb6da95c9b1
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12
- https://github.com/symfony/symfony/security/advisories/GHSA-6qh9-h6wf-jgqc
Get alerted when CVE-2026-45073 or the next vulnerability affects your stack