What’s Vulnerable › Vulnerabilities

CVE-2026-45133: Symfony: [Yaml] Harden the parser when handling untrusted input

Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Affected products

How to fix

Upgrade to a fixed version: symfony 5.4.52, 6.4.40, 7.4.12, 8.0.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-45133 or the next vulnerability affects your stack