What’s Vulnerable › Vulnerabilities
CVE-2026-45158: OPNsense: Command Injection via Attacker-Controlled DHCP Config
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-88
Description
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, unsanitized user input is passed to the DHCP configuration of the configured interface, which is processed by a shell script, allowing remote code execution as root on the underlying operating system. This vulnerability is fixed in 26.1.8.
Affected products
- OPNsense: before 26.1.8 — fixed in 26.1.8
How to fix
Upgrade to a fixed version: OPNsense 26.1.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-45158 or the next vulnerability affects your stack