What’s Vulnerable › Vulnerabilities
CVE-2026-45205: Apache Commons Configuration: StackOverflowError for YAML input with cycles
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-10-26
- Weakness: CWE-674
Description
Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Commons Configuration: from 2.2 before 2.15.0 — fixed in 2.15.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Commons Configuration 2.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/commons-configuration/pull/634
- https://lists.apache.org/thread/q3q3j10ohcqhs6o0rg1v7kz6kk27vtkk
- http://www.openwall.com/lists/oss-security/2026/05/14/5
Get alerted when CVE-2026-45205 or the next vulnerability affects your stack