What’s Vulnerable › Vulnerabilities

CVE-2026-45279: Nextcloud: Limited path traversal via template API if using `{lang}` in config

Description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 31.0.0 to before 31.0.14, and 32.0.0 to before 32.0.4, if {lang} is used in the template directory config value, non-admin users can in some cases copy arbitrary files (depending on unix permissions) into their own Nextcloud directory via a path traversal. It is recommended that the Nextcloud Server is upgraded to 32.0.4, 31.0.14. It is recommended that the Nextcloud Enterprise Server is upgraded to 32.0.4, 31.0.14, 30.0.17.7, 29.0.17.12, 28.0.14.15

Affected products

How to fix

Upgrade to a fixed version: Nextcloud Server 28.0.14.15, 29.0.17.12, 30.0.17.7, 31.0.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-45279 or the next vulnerability affects your stack