What’s Vulnerable › Vulnerabilities
CVE-2026-45281: Nextcloud: Cross-Account Calendar Takeover via Unauthorized Group-Member-Set Update
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-01 · updated 2026-07-22
- Weakness: CWE-639
Description
Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, with the knowledge of other users’ principal URL an attacker could possibly send a request to gain full access to their calendar. Therefore, the attacker must be an authenticated user. This is because of improper authorization controls in the backend of the calendar. If the attacker had access to the calendar, they would be able to view and modify it. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9, 29.0.16.16, 28.0.14.17, 27.1.11.26, 26.0.13.26, 25.0.13.29, 24.0.12.34, 23.0.12.35, 22.2.10.39, or 21.0.9.23
Affected products
- Nextcloud Server: from 32.0.0 before 32.0.9; from 33.0.0 before 33.0.3; from 21.0.0 before 21.0.9.23; from 22.0.0 before 22.2.10.39; from 23.0.0 before 23.0.12.35; from 24.0.0 before 24.0.12.34 — fixed in 21.0.9.23, 22.2.10.39, 23.0.12.35, 24.0.12.34, 25.0.13.29, 26.0.13.26
How to fix
Upgrade to a fixed version: Nextcloud Server 21.0.9.23, 22.2.10.39, 23.0.12.35, 24.0.12.34. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hrrv-mp25-26vv
- https://github.com/nextcloud/server/pull/59962
- https://hackerone.com/reports/3545964
Get alerted when CVE-2026-45281 or the next vulnerability affects your stack