What’s Vulnerable › Vulnerabilities
CVE-2026-45291: Cloudburst Network erroneously handles invalid connections
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-05 · updated 2026-10-26
- Weakness: CWE-20
Description
Cloudburst Network provides network components used within Cloudburst projects. A vulnerability in versions prior to `1.0.0.CR3-20260418.124334-32` impacts publicly accessible software depending on the affected versions of Network and allows an attacker to exploit a bug in Network to close the parent netty channel, rendering it inoperable. All consumers of the library should upgrade to at least version `1.0.0.CR3-20260418.124334-32`. There are no known workarounds beyond updating the library.
Affected products
- CloudburstMC Network: before 1.0.0.CR3-20260418.124334-32
References
Get alerted when CVE-2026-45291 or the next vulnerability affects your stack