What’s Vulnerable › Vulnerabilities
CVE-2026-45304: Symfony: YAML Parser Exponential Memory Allocation via Recursive Collection-Alias Expansion ("Billion Laughs")
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-07-15
- Weakness: CWE-776
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser resolved YAML collection aliases recursively, allowing a small untrusted YAML input to expand into a multi-gigabyte structure and exhaust memory. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Affected products
- symfony: before 5.4.52; from 6.0.0 before 6.4.40; from 7.0.0 before 7.4.12; from 8.0.0 before 8.0.12 — fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
How to fix
Upgrade to a fixed version: symfony 5.4.52, 6.4.40, 7.4.12, 8.0.12. Check the vendor advisory for mitigations.
References
- https://github.com/symfony/symfony/commit/e77391b2e4f18821198f010d573674c8ed4a970a
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12
- https://github.com/symfony/symfony/security/advisories/GHSA-4qpc-3hr4-r2p4
Get alerted when CVE-2026-45304 or the next vulnerability affects your stack