What’s Vulnerable › Vulnerabilities
CVE-2026-45353: electerm: Local code through electerm's single-instance socket
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-28 · updated 2026-06-17
- Weakness: CWE-94
Description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From 3.0.6 to 3.8.8, This vulnerability is fixed in 3.9.0.
Affected products
- electerm: from 3.0.6 before 3.9.0 — fixed in 3.9.0
How to fix
Upgrade to a fixed version: electerm 3.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/electerm/electerm/commit/0599e67069b00e376a2e962649aaad6096e63507
- https://github.com/electerm/electerm/security/advisories/GHSA-7p5m-v798-f8vv
Get alerted when CVE-2026-45353 or the next vulnerability affects your stack