What’s Vulnerable › Vulnerabilities
CVE-2026-45376: Decidim: Admin user search allows SQL injection through similarity-based sorting
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-31 · updated 2026-09-08
- Weakness: CWE-89
Description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, the GET /admin/organization/users search interpolates params[:term] into raw Arel.sql ORDER BY similarity expressions before sanitization, allowing an authenticated organization administrator to execute blind PostgreSQL expressions and infer data through timing differences. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Affected products
- decidim: before 0.30.9; from 0.31.0.rc1, < 0.31.5; from 0.32.0.rc1, < 0.32.0
References
- https://github.com/decidim/decidim/commit/27335957b363516e23919a9006812f1c458c88e0
- https://github.com/decidim/decidim/commit/e4d21b41fb462d9436035a043962a4090f2cc240
- https://github.com/decidim/decidim/commit/f3817fac448a4e3facd6bcb346167048b3421124
- https://github.com/decidim/decidim/releases/tag/v0.30.9
- https://github.com/decidim/decidim/releases/tag/v0.31.5
- https://github.com/decidim/decidim/releases/tag/v0.32.0.rc2
- https://github.com/decidim/decidim/security/advisories/GHSA-jvqq-cvh4-xm37
- https://github.com/decidim/decidim/security/advisories/GHSA-jvqq-cvh4-xm37
Get alerted when CVE-2026-45376 or the next vulnerability affects your stack