What’s Vulnerable › Vulnerabilities
CVE-2026-45415: Decidim: CSV census record endpoints improper authorization
- Severity: medium (CVSS 6.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-09-08
- Weakness: CWE-862
Description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, the /admin/csv_census/census_logs record-management endpoints do not enforce full administrator authorization before rendering or mutating Decidim::Verifications::CsvDatum, allowing a participant manager to create, alter, or remove census records. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Affected products
- decidim: before 0.30.9; from 0.31.0.rc1, < 0.31.5; from 0.32.0.rc1, < 0.32.0
References
- https://github.com/decidim/decidim/pull/16674
- https://github.com/decidim/decidim/pull/16703
- https://github.com/decidim/decidim/security/advisories/GHSA-q79h-67vx-m9xg
- https://github.com/decidim/decidim/security/advisories/GHSA-q79h-67vx-m9xg
Get alerted when CVE-2026-45415 or the next vulnerability affects your stack