What’s Vulnerable › Vulnerabilities
CVE-2026-45572: Decidim: HTML content blocks allow stored script execution
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-09-08
- Weakness: CWE-94
Description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, an administrator with landing-page editing privileges can store arbitrary HTML and JavaScript in an HTML content block, which Decidim::ContentBlocks::HtmlCell#html_content renders without sanitization, causing the script to execute in visitors' browsers. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Affected products
- decidim: before 0.30.9; from 0.31.0.rc1, < 0.31.5; from 0.32.0.rc1, < 0.32.0
References
- https://github.com/decidim/decidim/pull/16451
- https://github.com/decidim/decidim/security/advisories/GHSA-533c-2vh9-4r86
Get alerted when CVE-2026-45572 or the next vulnerability affects your stack