What’s Vulnerable › Vulnerabilities
CVE-2026-45573: Decidim: Push subscriptions can be abused for server-side requests
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-09-08
- Weakness: CWE-918
Description
Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, when VAPID delivery is enabled, the notification subscription flow stores a client-supplied push endpoint without validating that it belongs to an approved push service, and SendPushNotification later passes that endpoint to WebPush.payload_send, allowing an authenticated user to create stored, mostly blind server-side requests to arbitrary reachable HTTPS endpoints. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.
Affected products
- decidim: before 0.30.9; from 0.31.0.rc1, < 0.31.5; from 0.32.0.rc1, < 0.32.0
References
- https://github.com/decidim/decidim/pull/16714
- https://github.com/decidim/decidim/security/advisories/GHSA-2g9c-vf8h-prxx
Get alerted when CVE-2026-45573 or the next vulnerability affects your stack