What’s Vulnerable › Vulnerabilities
CVE-2026-45624: ImageMagick: Heap Buffer Over-Read of a 4 bytes in distort operation.
- Severity: medium (CVSS 5.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-07-23
- Weakness: CWE-125
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 6.9.13-47 and 7.1.2-22, when performing a polynomial distortion an out of bounds over-read of 24 bytes can occur when specifying specific arguments. This issue has been patched in versions 6.9.13-47 and 7.1.2-22.
Affected products
- ImageMagick: before 6.9.13-47; from 7.0.0-0 before 7.1.2-22 — fixed in 6.9.13-47, 7.1.2-22
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-47, 7.1.2-22. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-45624 or the next vulnerability affects your stack