What’s Vulnerable › Vulnerabilities

CVE-2026-45691: Nextcloud: Bypass of second factor authentication on DAV endpoints

Description

Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, a pre-2FA session cookie (created after successful password authentication but before TOTP completion) could be reused as a Bearer token to authenticate against DAV endpoints, granting read/write access and bypassing mandatory two-factor authentication. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9 or 29.0.16.16

Affected products

How to fix

Upgrade to a fixed version: Nextcloud Server 29.0.16.16, 30.0.17.9, 31.0.14.5, 32.0.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-45691 or the next vulnerability affects your stack