What’s Vulnerable › Vulnerabilities
CVE-2026-45694: LibreNMS: Reflected XSS in the Proxmox app view via unsanitized instance/vmid parameters
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-26 · updated 2026-09-09
- Weakness: CWE-79
Description
LibreNMS is a network monitoring system. In versions up to and including 26.4.0, the Proxmox application view is vulnerable to reflected cross-site scripting through the user-supplied instance and vmid GET parameters, which are reflected into the page title without adequate encoding. The parameters are placed into the page title with only strip_tags applied, and the title is then written into an inline document.title assignment through string interpolation, so a single quote terminates the JavaScript string and the remaining input runs as script. An attacker who lures an authenticated user into following a crafted link can execute script in that user's session, enabling actions such as theft of session data. This issue is fixed in version 26.5.0.
Affected products
- librenms: before 26.5.0
References
- https://github.com/librenms/librenms/commit/0be1bfd7746cea26bf7da40e82b70f75b724d0f8
- https://github.com/librenms/librenms/security/advisories/GHSA-jmqm-f8q4-v7wx
Get alerted when CVE-2026-45694 or the next vulnerability affects your stack