What’s Vulnerable › Vulnerabilities
CVE-2026-45746: Termix Vulnerable to Arbitrary Command Execution via Session Hijacking
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-05 · updated 2026-10-26
- Weakness: CWE-284
Description
Termix is a web-based server management platform with SSH terminal, tunneling, and file editing capabilities. Prior to version 2.3.2, the File Manager functionality in Termix contains a critical Broken Access Control vulnerability due to improper validation of the sessionId parameter. The backend trusts a client-controlled identifier without verifying that it belongs to the authenticated user. This allows an attacker to manipulate the value and access active File Manager sessions belonging to other users. Since these sessions are tied to SSH connections to remote VPS instances, exploitation allows unauthorized interaction with another user's remote filesystem. Because the File Manager exposes functionality such as file reading, writing, uploading, and execution, this vulnerability enables direct command execution on another user's VPS (RCE). Version 2.3.2 patches the issue.
Affected products
- Termix-SSH Termix: from 2.1.0 before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: Termix-SSH Termix 2.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/Termix-SSH/Termix/security/advisories/GHSA-cx2r-843c-vww8
- https://github.com/Termix-SSH/Termix/security/advisories/GHSA-cx2r-843c-vww8
Get alerted when CVE-2026-45746 or the next vulnerability affects your stack