What’s Vulnerable › Vulnerabilities
CVE-2026-45760: Apache Camel K: Camel K Cross-Namespace Build Deputy Attack
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-21 · updated 2026-07-23
- Weakness: CWE-610
Description
(Externally Controlled Reference to a Resource in Another Sphere), (Authorization Bypass Through User-Controlled Key) vulnerability in Apache Camel K. Authorized users in a Kubernetes namespace can create a Build resource, controlling the Pod generation in a namespace of their choice, including the operator namespace. This issue affects Apache Camel K: from 2.0.0 before 2.8.1, from 2.9.0 before 2.9.2, from 2.10.0 before 2.10.1. Users are recommended to upgrade to version 2.10.1 (or 2.8.1 or 2.9.2), which fixes the issue.
Affected products
- Apache Software Foundation Apache Camel: from 2.0.0 before 2.8.1; from 2.9.0 before 2.9.2; from 2.10.0 before 2.10.1 — fixed in 2.10.1, 2.8.1, 2.9.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Camel 2.10.1, 2.8.1, 2.9.2. Check the vendor advisory for mitigations.
References
- https://camel.apache.org/security/CVE-2026-45760.html
- http://www.openwall.com/lists/oss-security/2026/05/21/8
Get alerted when CVE-2026-45760 or the next vulnerability affects your stack