What’s Vulnerable › Vulnerabilities
CVE-2026-45784: rust-openssl: Potential out-of-bounds write in `CipherCtxRef::cipher_update_inplace` for AES-KW-PAD ciphers
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-07-29
- Weakness: CWE-131
Description
rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.10.50 until 0.10.80, CipherCtxRef::cipher_update_inplace in openssl/src/cipher_ctx.rs incorrectly sized output buffers when used with AES key-wrap-with-padding ciphers EVP_aes_{128,192,256}_wrap_pad. For a non-multiple-of-8 input, OpenSSL writes up to 7 bytes past the end of the caller's buffer or Vec, producing attacker-controllable heap corruption when the plaintext length is attacker-influenced. This issue is fixed in version 0.10.80.
Affected products
- sfackler openssl: from 0.10.50 before 0.10.80 — fixed in 0.10.80
How to fix
Upgrade to a fixed version: sfackler openssl 0.10.80. Check the vendor advisory for mitigations.
References
- https://github.com/rust-openssl/rust-openssl/commit/19eceb26f2404aae187e5444e65c404ebc1348a7
- https://github.com/rust-openssl/rust-openssl/pull/2638
- https://github.com/rust-openssl/rust-openssl/releases/tag/openssl-v0.10.80
- https://github.com/rust-openssl/rust-openssl/security/advisories/GHSA-phqj-4mhp-q6mq
Get alerted when CVE-2026-45784 or the next vulnerability affects your stack