What’s Vulnerable › Vulnerabilities
CVE-2026-45793: Composer: Github Actions issued GITHUB_TOKEN disclosure in GitHub Actions logs
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-07-15
- Weakness: CWE-200
Description
Composer is a dependency Manager for the PHP language. Prior to 1.10.28, 2.2.28, and 2.9.8, Composer\IO\BaseIO::loadConfiguration() validates GitHub OAuth tokens with the regex ^[.A-Za-z0-9_]+$ and interpolates rejected tokens into an UnexpectedValueException; GitHub Actions GITHUB_TOKEN values using the ghs_<id>_<base64url-JWT> format can contain -, fail validation, and be disclosed to stderr or CI logs. This issue is fixed in versions 1.10.28, 2.2.28, and 2.9.8.
Affected products
- Packagist Composer/Composer: from 2.3.0 before 2.9.8; from 2.0.0 before 2.2.28; from 1.0 before 1.10.28; 2.3.0, 2.3.1, 2.3.10, 2.3.2, 2.3.3, 2.3.4 (+214) — fixed in 2.9.8, 2.2.28, 1.10.28
- composer: from 1.0, < 1.10.28; from 2.0.0, < 2.2.28; from 2.3.0, < 2.9.8
How to fix
Upgrade to a fixed version: Packagist Composer/Composer 2.9.8, 2.2.28, 1.10.28. Check the vendor advisory for mitigations.
References
- https://github.com/composer/composer/commit/3f5e7f9fbfa541137d6d1d5643ec3b718e9d5039
- https://github.com/composer/composer/commit/65e6390c49f1a11cd8b660d81822086db51fe2d1
- https://github.com/composer/composer/commit/e66c8fdb7ff5409bd2f358c5f194038e49e93714
- https://github.com/composer/composer/pull/12853
- https://github.com/composer/composer/pull/12855
- https://github.com/composer/composer/releases/tag/1.10.28
- https://github.com/composer/composer/releases/tag/2.2.28
- https://github.com/composer/composer/releases/tag/2.9.8
- https://github.com/composer/composer/security/advisories/GHSA-f9f8-rm49-7jv2
Get alerted when CVE-2026-45793 or the next vulnerability affects your stack