What’s Vulnerable › Vulnerabilities
CVE-2026-45802: FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service
- Severity: medium (CVSS 6.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-10-26
- Weakness: CWE-400
Description
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.
Affected products
- Setasign FPDI: before 2.6.7
References
- https://github.com/Setasign/FPDI/commit/1695cfcc7e01fe844a7296b3de90855a3fa65be6
- https://github.com/Setasign/FPDI/releases/tag/v2.6.7
- https://github.com/Setasign/FPDI/security/advisories/GHSA-2mgw-7q6p-8grg
Get alerted when CVE-2026-45802 or the next vulnerability affects your stack