What’s Vulnerable › Vulnerabilities
CVE-2026-45809: OpenSIPS: Denial of Service in watcherinfo XML generation from oversized watcher URI
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-09-08
- Weakness: CWE-121
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.6.6 and 4.0.0-rc1 contain a denial of service vulnerability in the watcherinfo generation functionality. An attacker can create an oversized watcher entry by sending a SUBSCRIBE Event: presence request with a long From URI, and then trigger presence.winfo watcherinfo XML generation for the same presentity. OpenSIPS copies the stored watcher URI into a fixed-size stack buffer, overflowing it and crashing the process. A remote attacker can crash an OpenSIPS worker in deployments that expose handle_subscribe() and allow watcherinfo (presence.winfo) generation. The issue is configuration-dependent because the presence and presence_xml modules must be loaded and SUBSCRIBE routing must be reachable. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.
Affected products
- opensips: from 3.4.0, < 3.6.6; from 4.0.0-beta, < 4.0.0-rc1
References
- https://github.com/OpenSIPS/opensips/commit/c5970d3ee25b457ad2d78fe6e9662a12dae577cd
- https://github.com/OpenSIPS/opensips/commit/dd86461b71ff4a4f5194205896ae5f48f144240d
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-gx83-2gh8-7v56
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-gx83-2gh8-7v56
Get alerted when CVE-2026-45809 or the next vulnerability affects your stack