What’s Vulnerable › Vulnerabilities
CVE-2026-45811: Apache NimBLE: Buffer overflow in socket HCI transport
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-10-24
- Weakness: CWE-120
Description
Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in Apache NimBLE. The HCI socket transport did not check whether a received HCI event would fit the configured event pool before copying it, allowing a buffer overflow. Severity is low: exploitation requires either a misconfigured pool size or a malicious/compromised controller on the other end of the HCI socket link, not over-the-air Bluetooth access. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.10.0 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/mynewt-nimble/commit/dcc4e4f026109eecd507de9479bb5019306a4a41
- https://lists.apache.org/thread/5mkz68y1py0o6zmxtc3l1o8grtrb78m0
- http://www.openwall.com/lists/oss-security/2026/07/24/11
Get alerted when CVE-2026-45811 or the next vulnerability affects your stack