What’s Vulnerable › Vulnerabilities
CVE-2026-45813: Apache NimBLE: Incorrect data validation in BASS add/modify source operation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-10-24
- Weakness: CWE-191
Description
Out-of-bounds Write, Integer Underflow (Wrap or Wraparound) vulnerability in Apache NimBLE BASS service. Improper validation when parsing BASS service "Add Source" and "Modify Source" operation PDU could results in stack buffer overflow or arbitrary out-of-bound read. This can be triggered by nearby devices over Bluetooth connection, however pairing is required prior to accessing BASS service, which depending on device configuration may or may not require user action. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.10.0 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/mynewt-nimble/pull/2232
- https://lists.apache.org/thread/vc1ny73w243z5wr6t0y10gc6t2c9cytw
- http://www.openwall.com/lists/oss-security/2026/07/24/13
Get alerted when CVE-2026-45813 or the next vulnerability affects your stack