What’s Vulnerable › Vulnerabilities
CVE-2026-45815: Apache NimBLE: Remote reachable assertion in ATT Read Multiple Variable Response handler
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-10-24
- Weakness: CWE-617
Description
Reachable Assertion vulnerability in Apache NimBLE. A specially crafted ATT Read Multiple Variable Response (BLE_ATT_OP_READ_MULT_VAR_RSP) may trigger assert in ATT parser. Severity is medium as this requires DUT to first send ATT Read Multiple Variable Request. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.10.0 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/mynewt-nimble/commit/fae6a4874309ba0175d2c444e20f8a6bde007425
- https://lists.apache.org/thread/3d09hgo5zmm7dnryst3tb9857hk1bbos
- http://www.openwall.com/lists/oss-security/2026/07/24/14
Get alerted when CVE-2026-45815 or the next vulnerability affects your stack