What’s Vulnerable › Vulnerabilities
CVE-2026-45816: Apache NimBLE: NULL pointer dereference vulnerability in SMP LTK request
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-24 · updated 2026-10-24
- Weakness: CWE-476
Description
NULL Pointer Dereference vulnerability in Apache NimBLE in LE Long Term Key Request event. This requires disabled asserts (otherwise assert would trigger before NULL dereference) and bogus (or misbehaving) controller, thus severity is low. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.10.0 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/mynewt-nimble/commit/9448c5f495eb55018121b24a9dab5305c9222ea1
- https://lists.apache.org/thread/psppdk5j8jnq1m4jn96tnfofspgqvzvn
- http://www.openwall.com/lists/oss-security/2026/07/24/15
Get alerted when CVE-2026-45816 or the next vulnerability affects your stack