What’s Vulnerable › Vulnerabilities
CVE-2026-45847: net: remove WARN_ON_ONCE when accessing forward path array
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-06-25
- Weakness: CWE-617
Description
In the Linux kernel, the following vulnerability has been resolved: net: remove WARN_ON_ONCE when accessing forward path array Although unlikely, recent support for IPIP tunnels increases chances of reaching this WARN_ON_ONCE if userspace manages to build a sufficiently long forward path. Remove it.
Affected products
- Linux kernel: from 5.13 before 5.15.202; from 5.16 before 6.1.165; from 6.2 before 6.6.128; from 6.7 before 6.12.75; from 6.13 before 6.18.14; from 6.19 before 6.19.4 — fixed in 5.15.202, 6.1.165, 6.12.75, 6.18.14, 6.19.4, 6.6.128
How to fix
Upgrade to a fixed version: Linux kernel 5.15.202, 6.1.165, 6.12.75, 6.18.14. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/008e7a7c293b30bc43e4368dac6ea3808b75a572
- https://git.kernel.org/stable/c/50422613185d505201167e8bdd2f2700790d5db6
- https://git.kernel.org/stable/c/548244c2f542aa0ad49453e9306e715a3877bc44
- https://git.kernel.org/stable/c/9464ca7a6e56ad1ebf48b2ad5c16871edfad10c6
- https://git.kernel.org/stable/c/959ea349c7e2d4edf07b6838ca7e59345fe61a08
- https://git.kernel.org/stable/c/a78d055ba7c31103ad02f8eceb0c452e154d2660
- https://git.kernel.org/stable/c/dcf9b3c90e5560339649d088836529883fb509f3
Get alerted when CVE-2026-45847 or the next vulnerability affects your stack