What’s Vulnerable › Vulnerabilities
CVE-2026-45885: power: supply: cpcap-battery: Fix use-after-free in power_supply_changed()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-06-25
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: power: supply: cpcap-battery: Fix use-after-free in power_supply_changed() Using the `devm_` variant for requesting IRQ _before_ the `devm_` variant for allocating/registering the `power_supply` handle, means that the `power_supply` handle will be deallocated/unregistered _before_ the interrupt handler (since `devm_` naturally deallocates in reverse allocation order). This means that during removal, there is a race condition where an interrupt can fire just _after_ the `power_supply` handle has been freed, *but* just _before_ the corresponding unregistration of the IRQ handler has run. This will lead to the IRQ handler calling `power_supply_changed()` with a freed `power_supply` handle. Which usually crashes the system or otherwise silently corrupts the memory... Note that there is a similar situation which can also happen during `probe()`; the possibility of an interrupt firing _before_ registering the `power_supply` handle. This would then lead to the nasty situation of using the `power_supply` handle *uninitialized* in `power_supply_changed()`. Fix this racy use-after-free by making sure the IRQ is requested _after_ the registration of the `power_supply` handle.
Affected products
- Linux kernel: from 4.13 before 5.10.252; from 5.11 before 5.15.202; from 5.16 before 6.1.165; from 6.2 before 6.6.128; from 6.7 before 6.12.75; from 6.13 before 6.18.14 — fixed in 5.10.252, 5.15.202, 6.1.165, 6.12.75, 6.18.14, 6.19.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.252, 5.15.202, 6.1.165, 6.12.75. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2841bbb5a35c4449c0a0458e8e476b2a62f95147
- https://git.kernel.org/stable/c/2ce2334be155bd8bad6377e99984246ce4dbd08c
- https://git.kernel.org/stable/c/3ff75cba1c98349a23a8f9333981deba1972cc11
- https://git.kernel.org/stable/c/642f33e34b969eedec334738fd5df95d2dc42742
- https://git.kernel.org/stable/c/c549dd3de4b3f6e726d1b8386d40ccf7d3abdbe4
- https://git.kernel.org/stable/c/cbb9b07f88a9ef6518934c41eb3e8cf840d657d5
- https://git.kernel.org/stable/c/e261be6f18929f2397cd54cd583a2df624c129c1
- https://git.kernel.org/stable/c/f3fbe309c9bfe1aac1e2b26543e9dc4829f3275a
Get alerted when CVE-2026-45885 or the next vulnerability affects your stack