What’s Vulnerable › Vulnerabilities
CVE-2026-45902: power: supply: bq256xx: Fix use-after-free in power_supply_changed()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-06-24
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: power: supply: bq256xx: Fix use-after-free in power_supply_changed() Using the `devm_` variant for requesting IRQ _before_ the `devm_` variant for allocating/registering the `power_supply` handle, means that the `power_supply` handle will be deallocated/unregistered _before_ the interrupt handler (since `devm_` naturally deallocates in reverse allocation order). This means that during removal, there is a race condition where an interrupt can fire just _after_ the `power_supply` handle has been freed, *but* just _before_ the corresponding unregistration of the IRQ handler has run. This will lead to the IRQ handler calling `power_supply_changed()` with a freed `power_supply` handle. Which usually crashes the system or otherwise silently corrupts the memory... Note that there is a similar situation which can also happen during `probe()`; the possibility of an interrupt firing _before_ registering the `power_supply` handle. This would then lead to the nasty situation of using the `power_supply` handle *uninitialized* in `power_supply_changed()`. Fix this racy use-after-free by making sure the IRQ is requested _after_ the registration of the `power_supply` handle.
Affected products
- Linux kernel: from 5.12 before 5.15.202; from 5.16 before 6.1.165; from 6.2 before 6.6.128; from 6.7 before 6.12.75; from 6.13 before 6.18.14; from 6.19 before 6.19.4 — fixed in 5.15.202, 6.1.165, 6.12.75, 6.18.14, 6.19.4, 6.6.128
How to fix
Upgrade to a fixed version: Linux kernel 5.15.202, 6.1.165, 6.12.75, 6.18.14. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4b6fb0b6124f558131e502e3ffd03e6583b3ace6
- https://git.kernel.org/stable/c/74b5a88318db97d51bb40f774736553c2acd1514
- https://git.kernel.org/stable/c/8005843369723d9c8975b7c4202d1b85d6125302
- https://git.kernel.org/stable/c/81d3688c9a2158329391e08f2d0b8ba204216044
- https://git.kernel.org/stable/c/83c27fdd696ac13d023ef7a0345301be93209c53
- https://git.kernel.org/stable/c/8796910131a32ff29275052df768ef022929a394
- https://git.kernel.org/stable/c/cb5c743936edcebc51880eeb6bf04979b5c9438b
Get alerted when CVE-2026-45902 or the next vulnerability affects your stack