What’s Vulnerable › Vulnerabilities
CVE-2026-45914: Revert "hwmon: (ibmpex) fix use-after-free in high/low store"
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-06-24
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: Revert "hwmon: (ibmpex) fix use-after-free in high/low store" This reverts commit 6946c726c3f4c36f0f049e6f97e88c510b15f65d. Jean Delvare points out that the patch does not completely fix the reported problem, that it in fact introduces a (new) race condition, and that it may actually not be needed in the first place. Various AI reviews agree. Specific and relevant AI feedback: " This reordering sets the driver data to NULL before removing the sensor attributes in the loop below. ibmpex_show_sensor() retrieves this driver data via dev_get_drvdata() but does not check if it is NULL before dereferencing it to access data->sensors[]. If a userspace process reads a sensor file (like temp1_input) while this delete function is running, could it race with the dev_set_drvdata(..., NULL) call here and crash in ibmpex_show_sensor()? Would it be safer to keep the original order where device_remove_file() is called before clearing the driver data? device_remove_file() should wait for any active sysfs callbacks to complete, which might already prevent the use-after-free this patch intends to fix. " Revert the offending patch. If it can be shown that the originally reported alleged race condition does indeed exist, it can always be re-introduced with a complete fix.
Affected products
- Linux kernel: from 5.10.248 before 5.10.252; from 6.1.160 before 6.1.165; from 6.6.120 before 6.6.128; from 6.12.64 before 6.12.75; from 6.18.3 before 6.18.14; from 6.19.1 before 6.19.4 — fixed in 5.10.252, 6.1.165, 6.12.75, 6.18.14, 6.19.4, 6.6.128
How to fix
Upgrade to a fixed version: Linux kernel 5.10.252, 6.1.165, 6.12.75, 6.18.14. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/05112ba67c824ab416cd54307c0b50aba9f0047a
- https://git.kernel.org/stable/c/14a38784e09aebc21207dc32fffa05247fc3dd64
- https://git.kernel.org/stable/c/894d9c7aab68fd0c70c78b1d03c8fa589fb0f67d
- https://git.kernel.org/stable/c/8bde3e395a85017f12af2b0ba5c3684f5af9c006
- https://git.kernel.org/stable/c/914b47c9b824d3d74f31c764163edf93302100b1
- https://git.kernel.org/stable/c/efd68429f23fb4015b0ebc2392334059e06fad18
- https://git.kernel.org/stable/c/f448acd86835a650f9ea83460b9ca347d3aafba5
Get alerted when CVE-2026-45914 or the next vulnerability affects your stack