What’s Vulnerable › Vulnerabilities
CVE-2026-45916: power: supply: sbs-battery: Fix use-after-free in power_supply_changed()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-06-24
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: power: supply: sbs-battery: Fix use-after-free in power_supply_changed() Using the `devm_` variant for requesting IRQ _before_ the `devm_` variant for allocating/registering the `power_supply` handle, means that the `power_supply` handle will be deallocated/unregistered _before_ the interrupt handler (since `devm_` naturally deallocates in reverse allocation order). This means that during removal, there is a race condition where an interrupt can fire just _after_ the `power_supply` handle has been freed, *but* just _before_ the corresponding unregistration of the IRQ handler has run. This will lead to the IRQ handler calling `power_supply_changed()` with a freed `power_supply` handle. Which usually crashes the system or otherwise silently corrupts the memory... Note that there is a similar situation which can also happen during `probe()`; the possibility of an interrupt firing _before_ registering the `power_supply` handle. This would then lead to the nasty situation of using the `power_supply` handle *uninitialized* in `power_supply_changed()`. Fix this racy use-after-free by making sure the IRQ is requested _after_ the registration of the `power_supply` handle. Keep the old behavior of just printing a warning in case of any failures during the IRQ request and finishing the probe successfully.
Affected products
- Linux kernel: from 4.9 before 5.10.252; from 5.11 before 5.15.202; from 5.16 before 6.1.165; from 6.2 before 6.6.128; from 6.7 before 6.12.75; from 6.13 before 6.18.14 — fixed in 5.10.252, 5.15.202, 6.1.165, 6.12.75, 6.18.14, 6.19.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.252, 5.15.202, 6.1.165, 6.12.75. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/14d4dee5d8fb361bfff275832087254beab66d72
- https://git.kernel.org/stable/c/2078830c32d1e49ac942c6f8c21f35c806ae5e94
- https://git.kernel.org/stable/c/8010b745b436c3e1ca5dd960aa29fa3e0f6d8841
- https://git.kernel.org/stable/c/82d3eb97a976c9d56bb92b241397610e57a9c629
- https://git.kernel.org/stable/c/861dda7a9074c0ff67788928165ae39d7f647491
- https://git.kernel.org/stable/c/8d59cf3887fbabacef53bfba473e33e8a8d9d07b
- https://git.kernel.org/stable/c/ca7dd71773e4e050b0fb98768b7eae60f8d1f38b
- https://git.kernel.org/stable/c/f1f472b14ad56104ba228b8fbec60d5b21829913
Get alerted when CVE-2026-45916 or the next vulnerability affects your stack