What’s Vulnerable › Vulnerabilities
CVE-2026-45940: net: stmmac: fix oops when split header is enabled
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: net: stmmac: fix oops when split header is enabled For GMAC4, when split header is enabled, in some rare cases, the hardware does not fill buf2 of the first descriptor with payload. Thus we cannot assume buf2 is always fully filled if it is not the last descriptor. Otherwise, the length of buf2 of the second descriptor will be calculated wrong and cause an oops: Unable to handle kernel paging request at virtual address ffff00019246bfc0 ... x2 : 0000000000000040 x1 : ffff00019246bfc0 x0 : ffff00009246c000 Call trace: dcache_inval_poc+0x28/0x58 (P) dma_direct_sync_single_for_cpu+0x38/0x6c __dma_sync_single_for_cpu+0x34/0x6c stmmac_napi_poll_rx+0x8f0/0xb60 __napi_poll.constprop.0+0x30/0x144 net_rx_action+0x160/0x274 handle_softirqs+0x1b8/0x1fc ... To fix this, the PL bit-field in RDES3 register is used for all descriptors, whether it is the last descriptor or not.
Affected products
- Linux kernel: from 5.4 before 6.18.14; from 6.19 before 6.19.4 — fixed in 6.18.14, 6.19.4
- Linux: 5.4 — fixed in 7.0
How to fix
Upgrade to a fixed version: Linux kernel 6.18.14, 6.19.4; Linux 7.0. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/107e169f963920b11fa3c1bb384c077fe7330696
- https://git.kernel.org/stable/c/36f81cb7d82e9614a7058da6abdf2e3a03993df1
- https://git.kernel.org/stable/c/92b45c99311ac4f3857cccee47059c4fb067fd4d
- https://git.kernel.org/stable/c/a7fe1d75e087862bc4087f3fcdfd5e291b9d9caa
- https://git.kernel.org/stable/c/b1f23df09e7dbf4c86b6908dff7efb8cb2b7d609
- https://git.kernel.org/stable/c/babab1b42ed68877ef669a08384becf281ad2582
Get alerted when CVE-2026-45940 or the next vulnerability affects your stack