What’s Vulnerable › Vulnerabilities
CVE-2026-4600
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-23 · updated 2026-09-10
- Weakness: CWE-347
Description
Versions of the package jsrsasign before 11.1.1 are vulnerable to Improper Verification of Cryptographic Signature via the DSA domain-parameter validation in KJUR.crypto.DSA.setPublic (and the related DSA/X509 verification flow in src/dsa-2.0.js). An attacker can forge DSA signatures or X.509 certificates that X509.verifySignature() accepts by supplying malicious domain parameters such as g=1, y=1, and a fixed r=1, which make the verification equation true for any hash.
Affected products
- jsrsasign: before 11.1.1 — fixed in 11.1.1
How to fix
Upgrade to a fixed version: jsrsasign 11.1.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Kr0emer/bf15ddc097176e951659a24a8e9002a7
- https://github.com/kjur/jsrsasign/commit/37b4c06b145c7bfd6bc2a6df5d0a12c56b15ef60
- https://github.com/kjur/jsrsasign/pull/646
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-15812268
- https://security.snyk.io/vuln/SNYK-JS-JSRSASIGN-15370940
- https://access.redhat.com/errata/RHSA-2026:19375
- https://access.redhat.com/errata/RHSA-2026:19409
- https://access.redhat.com/errata/RHSA-2026:19410
- https://access.redhat.com/errata/RHSA-2026:6568
- https://access.redhat.com/errata/RHSA-2026:6720
- https://access.redhat.com/errata/RHSA-2026:6912
- https://access.redhat.com/errata/RHSA-2026:6926
Get alerted when CVE-2026-4600 or the next vulnerability affects your stack