What’s Vulnerable › Vulnerabilities
CVE-2026-4602
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-23 · updated 2026-09-10
- Weakness: CWE-681
Description
Versions of the package jsrsasign before 11.1.1 are vulnerable to Incorrect Conversion between Numeric Types due to handling negative exponents in ext/jsbn2.js. An attacker can force the computation of incorrect modular inverses and break signature verification by calling modPow with a negative exponent.
Affected products
- jsrsasign: before 11.1.1 — fixed in 11.1.1
How to fix
Upgrade to a fixed version: jsrsasign 11.1.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/Kr0emer/7ecd2be7d17419e4677315ef3758faf5
- https://github.com/kjur/jsrsasign/commit/5ea1c32bb2aa894b4bd29849839afe4f98728195
- https://github.com/kjur/jsrsasign/pull/650
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-15812274
- https://security.snyk.io/vuln/SNYK-JS-JSRSASIGN-15371175
- https://access.redhat.com/errata/RHSA-2026:19375
- https://access.redhat.com/errata/RHSA-2026:19409
- https://access.redhat.com/errata/RHSA-2026:19410
- https://access.redhat.com/errata/RHSA-2026:6568
- https://access.redhat.com/errata/RHSA-2026:6720
- https://access.redhat.com/errata/RHSA-2026:6912
- https://access.redhat.com/errata/RHSA-2026:6926
Get alerted when CVE-2026-4602 or the next vulnerability affects your stack