What’s Vulnerable › Vulnerabilities
CVE-2026-46082: KVM: SVM: Inject #UD for INVLPGA if EFER.SVME=0
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-06-24
Description
In the Linux kernel, the following vulnerability has been resolved: KVM: SVM: Inject #UD for INVLPGA if EFER.SVME=0 INVLPGA should cause a #UD when EFER.SVME is not set. Add a check to properly inject #UD when EFER.SVME=0. [sean: tag for stable@]
Affected products
- Linux kernel: from 2.6.32 before 5.15.209; from 5.16 before 6.1.175; from 6.2 before 6.6.140; from 6.7 before 6.12.86; from 6.13 before 6.18.27; from 6.19 before 7.0.4 — fixed in 5.15.209, 6.1.175, 6.12.86, 6.18.27, 6.6.140, 7.0.4
How to fix
Upgrade to a fixed version: Linux kernel 5.15.209, 6.1.175, 6.12.86, 6.18.27. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3ac9d4241d205f5d0df06358349ca718ebb0fa12
- https://git.kernel.org/stable/c/491139c17f8ad5773303068411f6ac5eed438b51
- https://git.kernel.org/stable/c/643125b66ffc1147c66616b749475ba9efb15971
- https://git.kernel.org/stable/c/c15392ed9e49c1a16b4d3a3ccf1b3bf2318a6c28
- https://git.kernel.org/stable/c/d99df02ff427f461102230f9c5b90a6c64ee8e23
- https://git.kernel.org/stable/c/ebb63390142c6458fc37758e0892759989cc159f
- https://git.kernel.org/stable/c/ee24928ecd85db4b68ed111e91fef36af0ca37b0
Get alerted when CVE-2026-46082 or the next vulnerability affects your stack