What’s Vulnerable › Vulnerabilities
CVE-2026-46085: rxrpc: Fix rxkad crypto unalignment handling
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-06-24
Description
In the Linux kernel, the following vulnerability has been resolved: rxrpc: Fix rxkad crypto unalignment handling Fix handling of a packet with a misaligned crypto length. Also handle non-ENOMEM errors from decryption by aborting. Further, remove the WARN_ON_ONCE() so that it can't be remotely triggered (a trace line can still be emitted).
Affected products
- Linux kernel: from 6.6.135 before 6.6.140; from 6.12.82 before 6.12.86; from 6.18.23 before 6.18.27; from 6.19.13 before 7.0; from 7.0.1 before 7.0.4; 7.0 — fixed in 6.12.86, 6.18.27, 6.6.140, 7.0, 7.0.4
How to fix
Upgrade to a fixed version: Linux kernel 6.12.86, 6.18.27, 6.6.140, 7.0. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/440d20d95e844b657a93a0b2dcc2aae155efdce6
- https://git.kernel.org/stable/c/af9271eb666d07b6f65612dc160a47f7cb5220ed
- https://git.kernel.org/stable/c/def304aae2edf321d2671fd6ca766a93c21f877e
- https://git.kernel.org/stable/c/f0d3efd03b2a9e0f1ffa6df8fcb264af3d494286
- https://git.kernel.org/stable/c/f1c6bd0cc786a8fa74829ce3c4b3673944a308f4
Get alerted when CVE-2026-46085 or the next vulnerability affects your stack