What’s Vulnerable › Vulnerabilities
CVE-2026-46104: selinux: use sk blob accessor in socket permission helpers
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-28 · updated 2026-06-25
Description
In the Linux kernel, the following vulnerability has been resolved: selinux: use sk blob accessor in socket permission helpers SELinux socket state lives in the composite LSM socket blob. sock_has_perm() and nlmsg_sock_has_extended_perms() currently dereference sk->sk_security directly, which assumes the SELinux socket blob is at offset zero. In stacked configurations that assumption does not hold. If another LSM allocates socket blob storage before SELinux, these helpers may read the wrong blob and feed invalid SID and class values into AVC checks. Use selinux_sock() instead of accessing sk->sk_security directly.
Affected products
- Linux kernel: from 6.13 before 6.18.30; from 6.19 before 7.0.7; 7.1-rc1 — fixed in 6.18.30, 7.0.7
How to fix
Upgrade to a fixed version: Linux kernel 6.18.30, 7.0.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/032e70aff025d7c519af9ab791cd084380619263
- https://git.kernel.org/stable/c/7eca71f57f194c1638ebb7f4097d6be8fd04c101
- https://git.kernel.org/stable/c/d350fef4bc2467fe1bce15f7a20fe60e01ce41ad
Get alerted when CVE-2026-46104 or the next vulnerability affects your stack