What’s Vulnerable › Vulnerabilities
CVE-2026-46200: spi: mpc52xx: fix controller deregistration
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-28 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: spi: mpc52xx: fix controller deregistration Make sure to deregister the controller before disabling and releasing underlying resources like interrupts and gpios during driver unbind.
Affected products
- Linux kernel: from 2.6.33 before 6.12.90; from 6.13 before 6.18.32; from 6.19 before 7.0.9 — fixed in 6.12.90, 6.18.32, 7.0.9
- Linux: 2.6.33 — fixed in 7.1
How to fix
Upgrade to a fixed version: Linux kernel 6.12.90, 6.18.32, 7.0.9; Linux 7.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0f997fdae819a8c2cc83bd4ff7d935ad76c727c9
- https://git.kernel.org/stable/c/28f28a0f4e327f792c230493a0ea00389ff68ff5
- https://git.kernel.org/stable/c/7fea80d93bfd34051b2ac1cec07766c87d8d28be
- https://git.kernel.org/stable/c/a3669f678d0ee8b686d3eea4c0ed9817c9374945
- https://git.kernel.org/stable/c/c6e3b9f5dcb80fe4d3f1e470f79a91a3cc526cee
- https://git.kernel.org/stable/c/ff2979c57b70be6d8b64e40d7b4217341a877fcd
Get alerted when CVE-2026-46200 or the next vulnerability affects your stack