What’s Vulnerable › Vulnerabilities
CVE-2026-46218: drm/amdgpu: Add bounds checking to ib_{get,set}_value
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-28 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amdgpu: Add bounds checking to ib_{get,set}_value The uvd/vce/vcn code accesses the IB at predefined offsets without checking that the IB is large enough. Check the bounds here. The caller is responsible for making sure it can handle arbitrary return values. Also make the idx a uint32_t to prevent overflows causing the condition to fail.
Affected products
- Linux kernel: from 4.2 before 6.1.175; from 6.2 before 6.6.140; from 6.7 before 6.12.90; from 6.13 before 6.18.32; from 6.19 before 7.0.9 — fixed in 6.1.175, 6.12.90, 6.18.32, 6.6.140, 7.0.9
How to fix
Upgrade to a fixed version: Linux kernel 6.1.175, 6.12.90, 6.18.32, 6.6.140. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0fb5cb556b249b2b64c0f818136c4c3e838ef53f
- https://git.kernel.org/stable/c/5da6c6430be0acb25b4242bce0323fc514d4e3cf
- https://git.kernel.org/stable/c/66085e206431ef88ce36f53c1f53d570790ccc9e
- https://git.kernel.org/stable/c/a853178d23e774adfe3a35073c375b04b3b20f7d
- https://git.kernel.org/stable/c/ee26fcf7c5cf131f0b6a732faa27d79ec61b8ec7
- https://git.kernel.org/stable/c/fec8b11b55e53ff51a741e56894fe331a516f5c6
Get alerted when CVE-2026-46218 or the next vulnerability affects your stack