What’s Vulnerable › Vulnerabilities
CVE-2026-4622
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-27 · updated 2026-10-26
- Weakness: CWE-78
Description
OS Command Injection vulnerability in NEC Platforms, Ltd. Aterm Series allows a attacker to execute arbitrary OS commands via network.
Affected products
- NEC Aterm Gb1200Pe Firmware: before 1.3.1 — fixed in 1.3.1
- NEC Aterm Wf1200Cr Firmware: before 1.6.0 — fixed in 1.6.0
- NEC Aterm Wg1200Cr Firmware: before 1.5.0 — fixed in 1.5.0
- NEC Aterm Wg2600Hm4 Firmware: before 1.4.2 — fixed in 1.4.2
- NEC Aterm Wg2600Hp4 Firmware: before 1.4.2 — fixed in 1.4.2
- NEC Aterm Wg2600Hs2 Firmware: before 1.3.2 — fixed in 1.3.2
- NEC Corporation Aterm WG2600HS: before 1.7.2 — fixed in 1.7.2
- NEC Aterm Wx3000Hp2 Firmware: before 1.3.2 — fixed in 1.3.2
- NEC Aterm Wx3000Hp Firmware: before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: NEC Aterm Gb1200Pe Firmware 1.3.1; NEC Aterm Wf1200Cr Firmware 1.6.0; NEC Aterm Wg1200Cr Firmware 1.5.0; NEC Aterm Wg2600Hm4 Firmware 1.4.2; NEC Aterm Wg2600Hp4 Firmware 1.4.2; NEC Aterm Wg2600Hs2 Firmware 1.3.2; NEC Corporation Aterm WG2600HS 1.7.2; NEC Aterm Wx3000Hp2 Firmware 1.3.2; NEC Aterm Wx3000Hp Firmware 2.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4622 or the next vulnerability affects your stack