What’s Vulnerable › Vulnerabilities
CVE-2026-46286: leds: qcom-lpg: Check for array overflow when selecting the high resolution
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-08 · updated 2026-07-23
Description
In the Linux kernel, the following vulnerability has been resolved: leds: qcom-lpg: Check for array overflow when selecting the high resolution When selecting the high resolution values from the array, FIELD_GET() is used to pull from a 3 bit register, yet the array being indexed has only 5 values in it. Odds are the hardware is sane, but just to be safe, properly check before just overflowing and reading random data and then setting up chip values based on that.
Affected products
- Linux kernel: from 6.4 before 6.6.140; from 6.7 before 6.12.86; from 6.13 before 6.18.27; from 6.19 before 7.0.4 — fixed in 6.12.86, 6.18.27, 6.6.140, 7.0.4
How to fix
Upgrade to a fixed version: Linux kernel 6.12.86, 6.18.27, 6.6.140, 7.0.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/28a2e047d03721e0517c67ee726eaa6621c30e5f
- https://git.kernel.org/stable/c/36ce3094dc50598f38fd961b46688cd533940efc
- https://git.kernel.org/stable/c/438e357b3cc6cd6900df271e4bc567bfe1142281
- https://git.kernel.org/stable/c/d45963a93c1495e9f1338fde91d0ebba8fd22474
- https://git.kernel.org/stable/c/f67a24e75d3251ba42538738120b6b659c0dca7d
Get alerted when CVE-2026-46286 or the next vulnerability affects your stack