What’s Vulnerable › Vulnerabilities
CVE-2026-46314: drm/v3d: Reject empty multisync extension to prevent infinite loop
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-08 · updated 2026-07-23
- Weakness: CWE-835
Description
In the Linux kernel, the following vulnerability has been resolved: drm/v3d: Reject empty multisync extension to prevent infinite loop v3d_get_extensions() walks a userspace-provided singly-linked list of ioctl extensions without any bound on the chain length. A local user can craft a self-referential extension (ext->next == &ext) with zero in_sync_count and out_sync_count, which bypasses the existing duplicate- extension guard: if (se->in_sync_count || se->out_sync_count) return -EINVAL; The guard never fires because v3d_get_multisync_post_deps() returns immediately when count is zero, leaving both fields at zero on every iteration. The result is an infinite loop in kernel context, blocking the calling thread and pegging a CPU core indefinitely. Fix this by rejecting a multisync extension where both in_sync_count and out_sync_count are zero in v3d_get_multisync_submit_deps(). An empty multisync carries no synchronization information and serves no useful purpose, so returning -EINVAL for such an extension is the correct defense against this attack vector.
Affected products
- Linux kernel: from 5.16 before 6.1.176; from 6.2 before 6.18.33; from 6.19 before 7.0.9 — fixed in 6.1.176, 6.18.33, 7.0.9
How to fix
Upgrade to a fixed version: Linux kernel 6.1.176, 6.18.33, 7.0.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/309abbddeca0c12714721928a819ef45e5710998
- https://git.kernel.org/stable/c/4fa42a249e8cd6ed17aea04e5695b6e9001f2433
- https://git.kernel.org/stable/c/9c5164781cb388d219d8f49fa0f0b04cf86ad544
- https://git.kernel.org/stable/c/fb44d589bf3148e13452185a6e772a7efbf2d684
Get alerted when CVE-2026-46314 or the next vulnerability affects your stack