What’s Vulnerable › Vulnerabilities
CVE-2026-46334: OpenSIPS: Denial of Service in SDP bandwidth parsing via QoS SDP cloning
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-09-08
- Weakness: CWE-20
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.6.6 and 4.0.0-rc1 contain a denial of service vulnerability in the SDP bandwidth-line parsing logic. A SIP request with Content-Type: application/sdp and a malformed session-level SDP bandwidth line missing the required colon delimiter can corrupt parsed SDP bandwidth metadata. When a route or module subsequently clones the corrupted SDP state, as occurs with dialog and QoS processing, the OpenSIPS worker process crashes. An unauthenticated remote attacker can therefore trigger a crash in any configuration whose routing script parses attacker-controlled SDP and applies dialog/QoS processing. This issue has been fixed in versions 3.6.6 and 4.0.0-rc1.
Affected products
- opensips: from 3.4.0, < 3.6.6; from 4.0.0-beta, < 4.0.0-rc1
References
- https://github.com/OpenSIPS/opensips/commit/8fe74b01f6fbf86c0b5e290735275530cb65e0fb
- https://github.com/OpenSIPS/opensips/commit/ac5309d5b8206cd3dbe1b4e01567c8db1ce31444
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-rh36-mhpv-cx2r
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-rh36-mhpv-cx2r
Get alerted when CVE-2026-46334 or the next vulnerability affects your stack