What’s Vulnerable › Vulnerabilities
CVE-2026-46367: phpMyFAQ - Stored XSS via Utils::parseUrl() in Comment Rendering
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-15 · updated 2026-10-26
- Weakness: CWE-79
Description
phpMyFAQ before 4.1.2 contains a stored cross-site scripting vulnerability in Utils::parseUrl() that allows authenticated users to inject JavaScript via malformed URLs in comments. Attackers can craft URLs with unescaped quotes to inject event handlers, stealing admin session cookies and achieving full application takeover when visitors view affected FAQ pages.
Affected products
- thorsten phpMyFAQ: from 4.1.1 before 4.1.2 — fixed in 4.1.2
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-9525-27vj-c8r8
- https://www.vulncheck.com/advisories/phpmyfaq-stored-xss-via-utils-parseurl-in-comment-rendering
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-9525-27vj-c8r8
Get alerted when CVE-2026-46367 or the next vulnerability affects your stack