What’s Vulnerable › Vulnerabilities
CVE-2026-46373: SQLFluff: Recursive Stack Overflow in Parser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-674
Description
SQLFluff is a modular SQL linter and auto-formatter with support for multiple dialects and templated code. Prior to version 4.1.0, in deployments where untrusted users can provide SQL queries to be linted, an untrusted user can submit a malicious query with deliberate excessive nesting to any application using the parser to trigger a Denial of Service through resource exhaustion. This issue has been patched in version 4.1.0.
Affected products
- sqlfluff: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: sqlfluff 4.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-46373 or the next vulnerability affects your stack