What’s Vulnerable › Vulnerabilities
CVE-2026-46420: setup-php: Command Injection in Repository-Derived PHP Version Resolution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-78
Description
setup-php is a GitHub action to set up PHP with extensions, php.ini configuration, coverage drivers, and tools. From 2.25.0 prior to 2.37.1, shivammathur/setup-php resolves the PHP version from repository-controlled files such as .php-version, composer.lock through platform-overrides.php, and composer.json through config.platform.php, and insufficiently constrains those values before incorporating them into generated shell or PowerShell setup scripts, allowing command injection on a GitHub Actions runner when workflows such as pull_request_target check out attacker-controlled contents before invoking setup-php. This issue is fixed in version 2.37.1.
Affected products
- shivammathur setup-php: from 2.25.0 before 2.37.1 — fixed in 2.37.1
How to fix
Upgrade to a fixed version: shivammathur setup-php 2.37.1. Check the vendor advisory for mitigations.
References
- https://github.com/shivammathur/setup-php/commit/eeef37e059fb5368a5bc8ed8ce45ff54bd39b80b
- https://github.com/shivammathur/setup-php/releases/tag/2.37.1
- https://github.com/shivammathur/setup-php/security/advisories/GHSA-pqwm-q9pv-ph8r
Get alerted when CVE-2026-46420 or the next vulnerability affects your stack