What’s Vulnerable › Vulnerabilities
CVE-2026-46425: Budibase: SCIM endpoints lack role-based authorization, BASIC users CRUD tenant users
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-27 · updated 2026-06-17
- Weakness: CWE-862
Description
Budibase is an open-source low-code platform. Prior to 3.38.2, packages/worker/src/api/routes/global/scim.ts attaches only two middlewares to the SCIM router: requireSCIM (checks the Enterprise feature flag and SCIM config) and doInScimContext (sets the SCIM request context). There is no role check. Any authenticated user who reaches the worker (BASIC role, workspace-scoped builder, anyone) can call SCIM endpoints and CRUD every user and group in the tenant. This vulnerability is fixed in 3.38.2.
Affected products
- budibase: before 3.38.2
References
- https://github.com/Budibase/budibase/releases/tag/3.38.2
- https://github.com/Budibase/budibase/security/advisories/GHSA-q9rw-q89f-jx2f
- https://github.com/Budibase/budibase/security/advisories/GHSA-q9rw-q89f-jx2f
Get alerted when CVE-2026-46425 or the next vulnerability affects your stack