What’s Vulnerable › Vulnerabilities
CVE-2026-46440: Flowise: Basic Auth Credentials Exposed via API
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-08 · updated 2026-07-23
- Weakness: CWE-522
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, the checkBasicAuth endpoint validates credentials in plaintext without rate limiting and with direct comparison. This issue has been patched in version 3.1.2.
Affected products
- FlowiseAI Flowise: before 3.1.2 — fixed in 3.1.2
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.2
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-php6-83fg-gw3g
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-php6-83fg-gw3g
Get alerted when CVE-2026-46440 or the next vulnerability affects your stack